> 太阳城娱乐网址 > 关于优炫 > 公司动态 > 业界新闻 >

业界新闻

Industry News

Sublime、Vim等多款流行文本编辑器存在特权升级漏洞

2018-03-19
据外媒 3 月 16 日报道,在最近一系列利用漏洞插件的攻击之后,SafeBreach的研究人员探讨了具有第三方可扩展性机制的高级文本编辑器如何被滥用来提升设备权限,并针对 Unix 和 Linux 系统检查了几种流行的可扩展文本编辑器(Sublime、Vim、Emacs、Gedit、pico / nano)。

经过研究发现,除 pico / nano 之外,所有受检查的编辑器都受到了一个关键的特权升级漏洞影响,攻击者可以利用这个漏洞在运行易受攻击的文本编辑器的目标设备上运行恶意代码。

据悉,大多数现代文本编辑器允许用户通过使用第三方插件来扩展功能,以此其增大攻击面。 相关研究人员认为这种情况非常严重,因为第三方插件可能会受到关键的特权升级漏洞影响,波及到类似 WordPress 、Windows 的 Chrome、Firefox 以及 Photoshop 等流行软件的插件。

目前该漏洞被认为与这些文本编辑器加载插件的方式有关,因为它们在加载插件时没有正确分离常规模式和高级模式。

emacs-text-editors

相关信息安全机构的研究表明,这些带有第三方插件的文本编辑器是另一种用来获得设备特权提升的方式,并且无论编辑器中是否打开了文件,使用这种方式来获得提升都能成功,即使是在 sudo 命令中运用常用的限制也可能无法阻止。

因此相关信息安全研究机构提供了的一些缓解措施:
○ 实施 OSEC 监督规则
○ 拒绝为非提升用户编写权限
○ 更改文件夹和文件权限模型以确保常规模式和高级模式之间的分离
○ 在编辑器升级时阻止加载第三方插件
○ 提供一个手动界面来批准提升的插件加载
内容来源:Security Affairs.
HackerNews.cc 编译
http://hackernews.cc/archives/21648
优炫操作系统安全增强系统(简称RS-CDPS)通过安装在服务器的安全内核保护服务器数据,通过截取系统调用实现对文件系统的访问控制,以加强操作系统安全性。

RS-CDPS具有完整的用户认证,访问控制及审计功能,不用更改操作系统就可以安装,提供信息系统主动防护功能,操作方便、易于系统管理和安全管理。

可对UNIX类、LINUX类、WINDOWS类各种操作系统进行统一管理,为管理人员提供方便,可以保障客户的服务器安全、持续、长效运行。